0

Since today I'm unable to log in my website as admin, there is always a toolbox at the top of the site but it just shows some useless information.

Adding /wp-login in my URL works, the IDs work and it redirects to my website with the same state of non-admin.

/wp-admin says I don't have the permissions. The last thing I did on my website is addind a visual plugin (GoPricing) which was well integreted. I did almost everything that's here : https://codex.wordpress.org/Login_Trouble but with no success.

It looks like the website knows I'm an admin but it does not redirect well (maybe?)

0

If you think that the plugin just installed is causing the problem, you can temporarily disable the plugin.

Assuming you have authorized FTP access to the site, look for the new plugin's folder in the wp-content/plugins folder of your site. The folder should have the same name as the plugin.

Rename that folder to something else (like 'my-plugin' to 'xxxmy-plugin'). Then try to log in again. Since the plugin folder is not correct, you might see a message about an invalid plugin; ignore it for now.

Assuming you can login, then the plugin might be the issue. If you can't log in (you get an invalid user/pass), then try the 'lost password' process. If resetting the password doesn't allow you to log in, then you've got problems in the user database (or someone hacked/disabled your user account).

Assuming you have CPanel access via your hosting place (assuming the site actually belongs to you and you have authorized access), you may need to go into the users table and fix your user id and authorization level via PHPAdmin. But that's beyond the scope of this answer (and there are many tutorials on how to do that).

Hoping that it is just a bad plugin. Anything more than that tends more to a 'hacked' problem. Again, assuming your site, your ownership, and nobody else has admin-level authority of your site.

  • I've already tested to rename the plugin folder with no success. One more thing I did is rename the prefix of my tables in phpmyadmin (wp_ by default). Could it come from here? – Charles Duporge Jan 11 '17 at 8:23
0

Finally found the answer ! As I said in my answer to Rick, I've renamed the prefix of the tables (wp_ to my_prefix_).

I renamed back to the default prefix (my_prefix_ to wp_) and it works well.

  • Hehehe :-) You can rename the prefix as long as it matches your database prefix – it is actually recommended to use something else other that the wp_ – user23355 Jan 11 '17 at 13:01
  • As a beginner I didn't know that when I started the project but I did it, it caused the admin problem. Maybe there were fields in tables that needed changes... – Charles Duporge Jan 11 '17 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.