0

Thanks in advance for any help guys,

For some reason my three pages stopped working, they just 301 to the home page. I think it may of been due to installing a plugin but I am not entirely sure.

I have since deleted the pages and re-created them, if I use the same slug they still 301 to the home page. However, if I change the slug to anything else they then work. It's like the original slugs are reserved somehow. But when i check the db there is only one post using the slug ie:

    SELECT count(*) FROM wp_posts where post_name = '$mySlugName';

I would expect if there was a conflict with the slug names that there would be more than one post using the name.

Other things I have tried:

  • Disabling plugins
  • Regenerating permalinks

I'm really not sure where to go with this now, may have to start debugging the core wordpress code base.

Cheers

  • 1
    Have you tried in multiple browsers? – czerspalace Jan 10 '17 at 20:51
  • I may be mistaken, but I believe WordPress keeps old slugs in options sometimes for SEO redirection. Maybe remove the old slug redirect or loop in your options table for _wp_old_slug – Howdy_McGee Jan 10 '17 at 20:58
  • Thanks for the replies guys, I have tried mutliple browsers and clearing caches. If behaves the same when I use wget on command line too. I've looked for old slugs, but the following query returns 0 rows: SELECT * FROM wp_postmeta WHERE meta_key = '_wp_old_slug' – Sydney Shaw Jan 11 '17 at 10:36
  • Have you tried testing in a fresh browser with the problem plugin disabled - you did after all suggest that this was the cause. – TheDeadMedic Jan 11 '17 at 13:25
  • @TheDeadMedic Thanks for the reply, the problem still persists when I disable all plugins unfortunately – Sydney Shaw Jan 11 '17 at 13:33
0

I had the same problem a few weeks ago, this is what solved it for me:

Went to Settings / Permalinks, switched to Plain and Saved. After that I changed Permalink settings back to the previously used values and it worked.

Let me know if this fixes your issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.