0

when I develope a new website for a client I use to work online on my server and then, when everything is ready, I move the website on client server. Sometimes happens that the website after the migration becomes really slow, while, on my server works perfectly.

Any ideas?

There is maybe something wrong in my code? This is an example Website (migrated)

4 Answers 4

1

I did a quick Network audit on Google Chrome and here`s what I found out:

  • the initial connection time to the website/domain is relatively low(500MS) which is a good thing.

  • the console throws an error: jquery.js?ver=1.12.4:4 GET http://www.ariatherm.ch/?_wpcf7_is_ajax_call=1&_wpcf7=460&_wpcf7_request_ver=1483396301637 which is related to the Contact Form 7 plugin.

  • the main problem seems to be related to the time elements require for download (see blue lines in this graphic https://snag.gy/uFKcnl.jpg )

From how I see things, this might be related to a poor webhosting infrastructure(shared server, old PHP/MySQL version, HDD and not SSD Drives, etc) so you might want to check that as well.

There are also heavy plugins used on the website like LayerSlider and Visual Composer which slow down the page. For LayerSlider, you can enable the ‘Conditional script loading’ and ‘Include scripts in the footer’ options in the ‘Troubleshooting & Advanced Settings’ section to increase the site’s performance.

Or maybe a plugin is faulty. Deactivate each plugin(except for VC, of course) and see how it goes. Start with Contact Form 7 and Ninja Contact Form.

Thanks!

1
  • @A.Casa Cheers!
    – Madalin
    Jan 4, 2017 at 21:41
0

This isn't really a WP question - but use a tool like Google Page Insights

https://developers.google.com/speed/pagespeed/insights/

to see where your site is slow. A quick look seems to show that the server is not configured for caching resources.

0

JS console gives the following error:

http://www.ariatherm.ch/?_wpcf7_is_ajax_call=1&_wpcf7=460&_wpcf7_request_ver=1483366044134 

Failed to load resource: the server responded with a status of 403 (Forbidden)

My guess would be wrong permissions on files/folders on the server.

0

You can optimize your site so that it can run faster even on shared server by performing following steps -

  1. Implement caching - By far my favorite is W3 Total Cache

  2. Optimize images - There is an amazing, free plugin called WP-SmushIt which will do this process to all of your images automatically.

  3. Optimize your WordPress database by using WP-Optimize plugin.

  4. Minify JS, CSS and HTML - https://wordpress.org/plugins/autoptimize/

In combination of these plugins, I am getting great results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.