0

I'd say about 50% of the time when I edit a post the 'update' is greyed out. What I do is copy the mark-up, refresh then re-apply and publish which is a bad work-around because it doesn't address the problem.

Any ideas? I guess I can disable plugins but because the error comes and goes it might take a long time to identify a rogue plugin....

I guess my question is - what would cause this behavior?

Thanks - and Happy NY 2017

  • Look in your browser's error console for any javascript errors. – Milo Jan 2 '17 at 2:48
  • I faced the same issue when my internet connection is slow. It happened when it tries saving auto-drafts but the internet connection is lost in the middle. – Mayeenul Islam Jan 2 '17 at 3:51
0

Update button is not always active. If the WordPress is auto-saving current post content, the update button will be disabled. This is normally done once every 60 seconds (default autosave interval). Auto-saving is done using AJAX, and if your website is slow to respond, autosave process can take a lot of time to finish.

Depending on the server, this can be from 1 second to 30 or more seconds. And, until autosave completes, the Update button is disabled.

You can change autosave frequency (WP-Config - Autosave Interval), or disable it completely. It is not recommended to do so, because if something goes wrong, you may lose your work. Autosave ensures that your content is saved in the database periodically to avoid data loss.

protected by Community Aug 7 '18 at 13:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.