1

I'm pulling my hair out here. I've done he following to update wordpress manually. The auto update does the same thing by the way.

  1. deactivate all the plugins manually by reseting my plugins folder.
  2. backing up my wordpress
  3. removing all the files as instructed at this url
  4. upload all the files per the instructions at the link.
  5. when it comes time to go to domain.com/wp-admin/upgrade.php I get a blank html area. My debug log shows cash errors in wordpress's core. here is the screenshot

I have tried reseting my browser to no avail. I really don't know what to do here. I've never in the almost 5 or 6 years I've used wordpress run into this problem with an upgrade, not even with my clients' websites.

3
  • Why are you doing it manually instead of using the built in updater?
    – Steve
    Dec 17, 2016 at 5:19
  • You wrote that your debug log shows errors. Please add a copy of these to your question. Else helpers can ouly guess about what is happeniing.
    – JHoffmann
    Dec 17, 2016 at 11:32
  • The reason I'm doing the manual updater is the automatic update brakes with the same empty html area. The debug log shows that in the wordpress core there is anthis error. Fatal error: Call to undefined function wp_cache_get() in /var/www/html/wp-includes/option.php on line 1117, ( I ge the nasty feeling I'm going to have to start over again. This is a self hosted site so no CPannel to help me start over. I'm using digital ocean to host the website.
    – user57081
    Dec 17, 2016 at 19:24

1 Answer 1

1

In trying the update again I got it to work. I don't know why the manual and auto update broke over the past few days. What ever was the cause on my remote's end is now fixed, or maybe it was me that did something wrong. I basically went through the instructions again and slowly did them step by step, preserving all of he files. I had to edit some constants in the config php file, as my site lost access to my wp directory. I can give a link to that article on how to do it if this happens to anyone. Thanks all.

One tip is to manually reset your plugins folder instead of deactivating all of them via the web interface. It's a geeky way to do this, but for me that seemed to help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.