I've got the opposite problem a lot of people can when switching servers. All the pages work fine, EXCEPT the home page, which is generating a 404. It's just the blog URL by itself (mysite.com/blogfolder/). Wordpress is installed in a folder in the site root, and worked fine at the old host. htaccess is all what it is supposed to be for this kind of installation. What could cause this??

3 Answers 3


If you are using a static page as homepage, make sure that the page which you were using as static homepage actually exists.


Have a look at this. It's fairly the same scenario.

  • It's not a static page, it's the Latest Posts. And, this was working fine at the previous host. Dec 19, 2016 at 16:19
  • Did you try rebuilding the Permalinks ?
    – Lunik
    Dec 19, 2016 at 22:36

I had the same problem after Ubuntu Upgrade 16.04 to 18.04, and it was solved by pressing "Purge Caches" in /wp-admin/admin.php?page=w3tc_objectcache


Try the following:

  1. Ensure that you have the right URL for Wordpress & Site Address in Settings > General
  2. Save permalinks in Settings > Permalinks
  3. Update the 'Your Homepage displays' in Settings > Readin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.