1

I have created a custom post type using CPT UI plugin, its slug is blog. I created a custom page named archive-blog.php. But WordPress always takes default archive.php. I'm confused what to do. I tried to add functions available in different websites. I tried to put has archive to true in the CPT UI. Please help

  • Probably has to do with your slug choice. Have you tried using something else? I don't see blog on the reserved terms list but I would try another option first and go from there. – jdm2112 Dec 7 '16 at 19:57
  • You could try creating a page with the slug 'blog' then using a page template instead. This has worked for me in the past. WP will serve the page with slug 'blog' instead of the cpt archive for 'blog'. – Jason Murray Dec 7 '16 at 21:40
  • @JasonMurray I already have a page template blog. – codieboie Dec 8 '16 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.