This morning most of the images on my wordpress blog (http://records.photodharma.net) have stopped loading.

This even happening on embeds. All the images here are embedded: http://records.photodharma.net/photos/chiang-mai-photo-albums-of-modern-structures When I view them in Firebug, they appear, but not on the page.

A couple of times I have seen images load and shortly after disappear, so it seems that they try to load but are being blocked.

I have done some searching and tried various things like updating the permalink settings, the media settings, etc. I also updated to the latest version of wordpress, and updated the .htaccess but nothing has worked.

Does anyone have any ideas about this?

  • Have you tried disabling all plugins, and switching to the twentyeleven theme? That's always the most basic troubleshooting step to test for any conflicts Aug 3, 2011 at 11:07
  • Thanks, that wasa good suggestion, but I just tried it, and still the images do not load.
    – Anandajoti
    Aug 3, 2011 at 11:28

4 Answers 4


I've opened one of the missing images on a different tab and a 'Forbidden 403' message appears. The page shows as follows:

403 Forbidden

You are not allowed to access this page. Possible problems:

  • Missing index file
  • Misconfigured mod_rewrite settings in .htaccess
  • Authentication Failure
  • Incorrect file or folder permissions

Which are valid reasons you should try to check out. The folder permissions could be the answer to your problem, but if you haven't made any special changes on your server or blog admin, I think the .htaccess could be the solution.

The typical

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
# END WordPress

should be in your .htaccess. And check if you've got mod_rewrite enabled with

a2enmod rewrite

on your server. Hope this helps.

  • Hi javipas, and thanks for the reply. Now if you take that link and don't middle click it to open it (ie from the troublesome site), but copy and paste it into a new tab it loads. The same htaccess controlling the photodharma.net site (where the image is) controls the records.photodharma.net where the image will not load. So it can't be the htaccess, which is correctly written anyway. The folder settings must be OK, cause it works elsewhere. I have written to the admin to show him this Q&A, and asked him to check the database settings (I can't do it).
    – Anandajoti
    Aug 3, 2011 at 12:57

The odd thing I see here is they load when you direct link to them, like this:


Maybe check your permissions? Make sure that the folders and files have proper permissions to them? Honestly it is a guess, as I don't believe we would be able to see them by direct link if the permissions were wrong.

  • Hi Tom, don't think it can be permissions on a range of files which load on another site, but not on this one. As I say I can see them, even in the page with Firebug, but they don't load.
    – Anandajoti
    Aug 3, 2011 at 12:21

If the image loads directly from photodharma.net, but not from records.photodharma.net, then I suspect that you might have hotlinking disabled.

Do you have any hotlinking-prevention rules your .htaccess file? Do you have any Plugins active that are preventing hotlinking.

Note: if the issue is hotlinking prevention, you will need to check .htaccess and Plugins on photodharma.net, not on records.photodharma.net.


If you've got no hotlink protection anywhere, then the next likely culprit is file/folder permissions.

What are the permissions on http://www.photodharma.net/Blog/images/?

  • Hi Chip, I have no hotlinking rules in the htaccess and no plugins preventing it. Indeed I have been using hotlinking since I started the blog and everything has been OK up and till now.
    – Anandajoti
    Aug 3, 2011 at 22:06
  • Okay, next likely culprit: file/folder permissions. See answer edit. Aug 4, 2011 at 2:53
  • Thanks Chip, I just checked the permissions, they are 755. But in any case, no images are loading from anywhere on that site, even though all the images can be accessed individually, just not on the webpage. I've seen that a number of times they try to load, appear for a second, and then are taken down as though they were blocked. Strange, huh?
    – Anandajoti
    Aug 4, 2011 at 4:13
  • Hi Chip, it turned out to be a hotlinking problem,. someone had changed the setting in the Control Panel so hotlinks were disabled. Now fixed. Many thanks to all who helped with this.
    – Anandajoti
    Aug 4, 2011 at 6:32
  • Good for Chip, didn't think of that one ;) Anandajoti, remember, if that has solved your problem, you should accept his answer.
    – javipas
    Aug 4, 2011 at 16:24

Talk to your host servage.net. They must have made some changes in their Apache config for ownership/permissions of the account or in mod_rewrite.

Dev tools shows "Failed to load resource: the server responded with a status of 403 (Forbidden)" so that means a directory level issue, even though you can load the direct image URL in a new window and see it.

  • Thanks for that songdogtech, I have opened a ticket with servage to see if they can find the problem.
    – Anandajoti
    Aug 4, 2011 at 5:34
  • Hi songdogtech, it turned out to be a hotlinking problem,. someone had changed the setting in the Control Panel so hotlinks were disabled. Now fixed. Many thanks for helping with this.
    – Anandajoti
    Aug 4, 2011 at 6:33
  • I mean in the Servage Control Panel (not Wordpress), which I don't normally have access to. Many thanks to all who helped.
    – Anandajoti
    Aug 4, 2011 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.