0

I'm getting a HTTP 500 Error on my website. Not sure what it could be. But when I refresh the page, everything works correctly. Here goes the exact error

The www.brothas.online page isn’t working

www.brothas.online is currently unable to handle this request. HTTP ERROR 500

Usually it happens when trying to login or access the back end of the website. Any help or questions would be much appreciated. Thanks

  • in your wordpress root folder find file wp-config.php in that file make define('WP_DEBUG',true); and check what is the error – Govind Kumar Nov 27 '16 at 3:29
0

You've got an SSL certificate on the site.

So start by telling people to go to https://brothas.online instead of the link above ;)

More importantly:

Second go 'Settings' -> 'General' and set both 'WordPress Address (URL)' and 'Site Address (URL)' to 'https://brothas.online'

Then go to 'Settings' -> 'Permalinks' and save you settings again.

This should fix the redirect error.

If those steps don't fix it, you may have an issue with your .htaccess file. Rename it and save your Permalinks again.

Here are a few popular articles for more in-dept support:

https://www.elegantthemes.com/blog/tips-tricks/how-to-fix-the-500-internal-server-error-on-your-wordpress-website

http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-internal-server-error-in-wordpress/

I encourage you to try my tricks before going down the rabit hole.

  • Tell your hosting company about this. Sometimes they can look at the logs and see an issue for you. – Nohl Nov 28 '16 at 18:19
0

Thanks I appreciate your response. I actually had both 'WordPress Address (URL)' and ' Site Address (URL)' saved as https://brothas.online . Tripled checked. Although it did not really start happening until I did get my SSL Certificate installed. Renamed the .htaccess file on FTP. Then went into 'Settings' -> 'Permalinks' and clicked saved. Got a error from a plugin I used (Really Simple SSL) the error was "Your .htaccess does not contain the Really Simple SSL redirect to https, and could not be written, so a javascript redirect is currently added. For SEO purposes it is advisable to use .htaccess redirects. Set the .htaccess file to writable and visit the settings page to write it again, or copy the code lines from the settings page."

Deactivated the plugin Really Simple SSL, which removed the error and since I renamed the .htaccess file and went to 'Settings' -> 'Permalinks' and saved it looks like it fixed the issue. Thank you so much. Been trying to figure this issue out for the longest.

  • I also did WP_DEBUG true. Was getting a memory limit error. Went into php.ini to increase my memory limits. – gshustle Nov 27 '16 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.