0

I want to use wordpress multisite. So I add code to wp-config.php:

define( 'WP_ALLOW_MULTISITE', true );

define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'localhost');
define('PATH_CURRENT_SITE', '/multi/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

Also I have added code to my .htaccess file:

RewriteEngine On
RewriteBase /multi/
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) D:/localhost/Multi/$2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ D:localhost/Multi/$2 [L]
RewriteRule . index.php [L]

Also I have created second website - multi/second And I can see frontend of second website ( posts / images ... )

but when I try to use admin panel - multi/second/wp-admin I get

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.
0

Sounds like you install WordPress on a subdirectory (/multi) and on localhost? Can you log in the main site admin: /multi/wp-admin?

The error is to do with "permission to access the requested directory", it's probably not to do with WordPress settings/config.

Check your WP installation again for potential missing steps (which might cause the permission issue) with this: https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-debian and this: https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-on-debian-7 (I do exactly as the guide and don't have any error when activate multisite, WP4.7 on Debian 8.6)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.