0

I'm currently migrating a wordpress site to a live server. When trying to import my database via phpMyAdmin I run across the following error below:

Error

 CREATE TABLE  `wp_commentmeta` (

  `meta_id` BIGINT( 20 ) UNSIGNED NOT NULL ,
  `comment_id` BIGINT( 20 ) UNSIGNED NOT NULL DEFAULT  '0',
  `meta_key` VARCHAR( 255 ) COLLATE utf8mb4_unicode_520_ci DEFAULT NULL ,
  `meta_value` LONGTEXT COLLATE utf8mb4_unicode_520_ci
 ) ENGINE = INNODB DEFAULT CHARSET = utf8mb4 COLLATE = utf8mb4_unicode_520_ci;

How can I swiftly resolve this?

  • This is not an error, it is a SQL statement. – fuxia Nov 20 '16 at 0:34
  • this is incomplete. please include the full error so we could help – elicohenator Nov 20 '16 at 8:13
0

To move a site from localhost i usually do the following:

1, Install adminer plugin on your localhost (lets you download the database file)

2, Use an FTP to upload all files

3, Change the php config files details to work on host

4, Open the mysql file saved from Adminer and then edit the wp_options section change both "siteurl" & "home" to point to your url for site.

5, Go to your url and then run the install of wordpress and after this activate Adminer then just import the admirer file you download or if you know mysql import the file from the mysql panel on your hosts cpanel.

6, You should now be able to see the wordless site but the last thing you will need to do is go to settings -> permalinks and change them to "plain" then back to "post name" and you can view the sites sub pages correctly as this recreates the .htacccess file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.