0

I've recently switched to Linux Fedora, and I moved all my xampp files to my new installation, as well as importing the databases.

Now I'm facing an odd problem, a couple of weeks ago I've created a new page on Windows and called it Resources, and created the page-resources.php file for it, it was working well.

I'm trying to access the url localhost/site/resources which was the permalink for the page I created, however, it's redirecting me to localhost/site/ which is the home page, I tried changing the permalink settings, turning off all plugins, resetting my .htaccess file, even changing my site url, but no chance, and I don't know what to do.

Note: if I change the page permalink and the page slug from files, it actually works !, like if I added a letter to the name to be localhost/site/resourcess as well as changing the php page slug file, it's loading the page.

UPDATE: Fixed by clearing browser's cache data and cookies :3 :D

  • 1
    Thanks for the update, Mohammed. Can you please post your solution as an answer, then stop by in a couple of days and accept it? This will clear your question out of the unanswered queue. – Dave Romsey Nov 16 '16 at 20:00
0

UPDATE: I fixed it by clearing my browser's cache, it was caching files so it used the old copy.

BONUS: You can load a web page without loading your caches by using Ctrl + F5

0

Change your permalinks settings to something different, and save it. Then go back to the original settings, and save it. That should clean up your htaccess file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.