0

I'm getting a really weird error.

My entire blog works perfectly, except for the post-new.php page (Posts -> Add New).

I have debugging turned on via the config file but nothing shows in the debug.log or error_log files regarding post-new.php.

It simply re-directs to /500.shtml

Just to see what was up, I made a backup of post-new.php and just put "Hello world" in the file. It still goes straight to /500.shtml. So clearly it's not even getting to post-new.php

Btw, my blog was working perfectly yesterday but I had gone over my host's resource limit and initially even /wp-login was showing 500.shtml, but slowly the site came back online, but post-new is still not working.

Thanks for the help!

  • 1
    What error actually it is throwing ?? 404 or 500 ? – CodeMascot Nov 16 '16 at 7:00
  • 1
    it is throwing 500 – Varun Nov 16 '16 at 8:05
  • try checking newly created file has 0666 permission – Third Essential Designer Nov 16 '16 at 9:30
1

Internal server errors (error 500) are often caused by plugin or theme function conflicts, so if you have access to your admin panel, try deactivating all plugins. If you don’t have access to your admin panel, try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

If that does not resolve the issue, try switching to the Twenty Fifteen theme to rule-out a theme-specific issue. If you don’t have access to your admin panel, access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue.

If that does not resolve the issue, it’s possible that a .htaccess rule could be the source of the problem. To check for this, access your server via FTP or SFTP and rename the .htaccess file. If you can’t find a .htaccess file, make sure that you have set your FTP or SFTP client to view invisible files. Better go to Settings >> Permalinks and hit Save Changes button. It will regenerate your .htaccess file.

Hope this helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.