My visual editor isn't working on a site after just launching it to a new server. I assumed a permissions issue, but the file itself is set to 644. I tried 755 on it as well and still no go. The directories all the way up are 755.

I can access other files in the directory, but not this one file. Any ideas?

2 Answers 2


wp-tinymce.php loads to the WordPress dashboard using Ajax on your end.

So the permission for that file should be 664. But the problem is your /wp-include folder may not allow remote PHP execution. This may be either in .htaccess via some security plugin you are using or somewhere in Nginx rules.

Further, I think you are using some plugin that calls wp-tinymce.php in a strange way.


This can also be caused by the .htaccess placed in the wp-includes folder by iThemes Security as a hardening measure. That file might be invisible to you depending on your FTP client's settings.

I've personally seen it happen with iThemes Security v6.2.1 on WP 4.8 on php 7.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.