0

I am working on Arabic wordpress website and I have a problem when using arabic title for the post. the single post page always redirect to home page but with english permalinks it work perfectly

My web.config

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<rewrite>
<rules>
<rule name="WordPress Rule" stopProcessing="true">
<match url=".*" />
<conditions>
<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
</conditions>
<action type="Rewrite" url="index.php" />
</rule>
</rules>
</rewrite>
</system.webServer>
</configuration>

Any help will be appreciated.

3
  • Unable to replicate using Nginx, this could be an IIS issue, but further information will be needed, such as what the query vars are ( install the Query Monitor plugin to see these )
    – Tom J Nowell
    Nov 5, 2016 at 15:51
  • did you follow up on @tom-j-nowell suggestion? Did you do a Network inspection using the page inspector in Firefox/Chrome to see the page code being returned?
    – Aurovrata
    Nov 18, 2016 at 13:53
  • Have you tried changing Permalink Settings to anything else? You can change it to a different pattern, save it and then change it back again.
    – Kalimah
    Nov 20, 2016 at 11:40

1 Answer 1

1

IIS has a problem with RTL-languages in URLs. Check your database and page encoding is UTF-8. After that try to put into system.webServer tag <globalization requestEncoding="utf-8" responseEncoding="utf-8" fileEncoding="utf-8" />

If it does not help you may use free WordPress plugin Custom Transliteration with Arabic Transliteration

1
  • thanks for your answe. <globalization requestEncoding="utf-8" responseEncoding="utf-8" fileEncoding="utf-8" /> cause internal server error and the plugin solution didn't worked too :( Nov 22, 2016 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.