7

screenshot

Hii, I don't have the add new button.How to install a new theme?

2
10

In my case, the button was missing because it was a multisite install. The Add New button appears only when you go to top bar -> My Sites -> Network Admin -> Themes. From there, you can add new themes and enable them for the rest of the network.

2

Edit config file Go to cpanel -> File Manager -> wp-config.php Click on edit

Scroll to the bottom Change define('DISALLOW_FILE_EDIT', true); define('DISALLOW_FILE_MODS', true);

to define('DISALLOW_FILE_EDIT', false); define('DISALLOW_FILE_MODS', false);

This fixed it for me

1

Themes are just sub-folders in wp-content/themes, when you upload a theme in a zip file to the themes page, it just unzips the file into that folder. If it's a valid theme then it shows up on that page.

If for whatever reason this functionality is disabled, or write access isn't possible, that option won't present itself in the user interface, but I would recommend using the manual process instead

1

Never ran through such problem but I can suggest you to do the following:

If you are a linux user:

$cd path_to_your_wordpress_site/wp-content/
ls -lah
$sudo chmod -R 755 themes

Here h flag to ls command will show you all the ownerships and permissions related to the file. If it didn't help either

go to the root directory of the web server:

sudo chown -R www-data:www-data your_wordpress_site_folder

above command is for ubuntu

for centos

$sudo chown -R apache:apache your_wordpress_site_folder

I hope it helps.

1

This might be the problem. The feature only exists for wordpress.ORG and not for sites exists on WordPress.COM

2
  • This could be the issue for someone else, but the OP's screenshot indicates that the site is being run via localhost, so it's a .org site in this case. Mar 15 '19 at 0:44
  • 1
    Okay. Yeah. My mistake. It was for me :)
    – Pushpa
    Mar 15 '19 at 1:43
1

edit the file 'wp-config.php'

define('DISALLOW_FILE_MODS', false);
1

Why does this happen?
It usually happens, if you enable

Softaculous Apps Installer> WordPress> Enable Multisite (WPMU),


In this case, Wordpress creates 'Network Admin' alongside 'Admin' for using WPMU. Which allows you to upload the theme from 'Network Admin' only.

What to do now?
Simply re-install and make sure you haven't enabled the option like the image below. WPMU


What if I wanna use the option?
You can simply go to their official website WPMU and learn how to use the features in details.

1

define('DISALLOW_FILE_MODS', true); - this was my case, but it wasn't in the wp-config.php, instead, it was in the theme's functions.php file!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.