1

I'm on Ubuntu and using LAMP for local dev. I've several WordPress installations for different project and tried to set custom permalinks on all of them, but only default permalink setting ( http://localhost/wpinstalation/?p=123 ) works, other settings are giving 404 error. Any idea how can I fix this?

George

1 Answer 1

3

I had the same problem. It sounds like you don't have rewrites turned on in your installation.

Find your httpd.conf file, find the following line:

#LoadModule rewrite_module modules/mod_rewrite.so

And remove the # at the beginning so it looks like this:

LoadModule rewrite_module modules/mod_rewrite.so

Save and then restart the service. Custom Permalinks should now work. There might be an easier way but I'm not familiar with Linux

3
  • Thanks Manny but mod_rewrite wasn't installed. This answer solved my problem: askubuntu.com/questions/48362/…
    – Mamaduka
    Commented Jul 31, 2011 at 7:51
  • oh, thanks! I thought that other answer did the job for you, though. Commented Aug 16, 2011 at 20:15
  • yes, but from that answer I just got tips for mod_rewrite :)
    – Mamaduka
    Commented Aug 16, 2011 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.