0

I'm running wordpress, auto-installed using the optimizied a2 hosting cpanel link. I use the 2014 theme. I updated to the most recent 4.6.1 core.

It's not autosaving as described here: Wordpress Autosave.

Instead, it looks like this:

enter image description here

On several occasions, I've lost work. Sometimes, I get an "are you sure you want to do this" popup, and it reverts to just before the last time I clicked the "save draft" button.

I've search for an answer, but the results all talk about turning it off. I want it on.

  • 1
    @Aniket that is not correct. WordPress autosave to database and also use browser's local storage, it uses both. In fact, autosave to database was first, browser's local storage was introduced later (WP 3.6) to help if user lost internet connection. Anyway, the linked page in the question is about WordPress.com service not, about the software of WordPress.org – cybmeta Nov 2 '16 at 9:51
  • I've tried both Chrome and Firefox (on Ubuntu) and it doesn't change anything. I didn't mess with privacy/cache settings on either. – mmccoo Nov 3 '16 at 8:58
0

You are looking for the reference of auto-save in wordpress.com. I think you can have a look to your wp-config.php to see if you have a define about the auto-save interval.

When editing a post, WordPress uses Ajax to auto-save revisions to the post as you edit. You may want to increase this setting for longer delays in between auto-saves, or decrease the setting to make sure you never lose changes. The default is 60 seconds.

Editing wp-config.php

define( 'AUTOSAVE_INTERVAL', 160 ); // Seconds

If you find this line, you can remove it, and the autosave functionnalities will come back. If you use any cache plugin, you maybe need to manage its options.

  • I'm removed the W3 Total Cache plugin. I also grepped for AUTOSAVE_INTERVAL and only default_constants and script loader appeared. The only thing that changed is that the purge from cache link went away. ;-( – mmccoo Nov 3 '16 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.