0

I recently realized that my rss feed is not working, because a plugin was assuming it's under

mydomain.com/feed

But it isn't. I get an 404 error. I figured out that instead my feed is under

mydomain.com/index.php/feed

I already had similar issues in the past when using Easy Affiliate Links. For example when I created a link that was supposed to be:

mydomain.com/visit/google

The link that worked was

mydomain.com/index.php/visit/google

My blog url is equally annoying:

mydomain.com/index.php/blog

It's not a minor annoyance any more. I need to get "index.php" completely removed from my url structure. I'm assuming it's some kind of misconfiguration. How do I fix it?

2
  • What kind of server are you using? Do you have an .htaccess file? Oct 26, 2016 at 20:33
  • I'm on hostgator. But I just solved the problem by browsing all the menus. Will post my answer soon. For some reason Settings->Permalinks was set to Custom configuration.
    – evolution
    Oct 26, 2016 at 20:42

1 Answer 1

2

After browsing all my dashboard, the solution turned out to be simple:

Navigate to:

Dashboard -> settings -> permalinks

For some reason "Custom structure" was activated. I simply had to choose "Post name" instead.

Now all my links look as they should.

1
  • The reason could be that WordPress was no able to detect that mod_rewrite module was active on the webserver. Then all urls had to be relative to index.php. Oct 9, 2019 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.