0

I moved a wordpress site that uses a custom built theme from one server to another using the xml export/import feature. I also exported the SQL database and uploaded to new server. I also imported all upload images into the media library.

For the most part, the site looks good, but when I go to each page, the on-page assigned images are not there. For hero images, it simply shows the image uploader (it is not showing that an images is already assigned as it had been on the old server). Same for rotator images, etc. They all seem to need to be re-set.

I have tried to delete all pages and re-import, as I didn't import the images until afterward before and thought maybe since they weren't there the pages wouldn't be able to reference, but it didn't do anything to fix.

I am wondering if this might be a theme-specific issue or if I missed a step somewhere. I did not develop the theme itself.

  • You'll need to import or upload the images into the media library and relink them. – Greg McMullen Oct 22 '16 at 0:49
0

The XML export/import feature does not transfer the uploads folder inside the wp-content. So you need to transfer those too to your new site from old site. I think following the below steps from ground up will be better-

  1. First zip the wp-content folder or directory and download it.
  2. Then backup the database.
  3. After backing up the database, download the database after cleaning the WordPress serialized data. I use this tool. And it works pretty well. You can also do that after downloading the database with any text editor. But the first way is pretty safe cause WordPress saves many serialized data in database.
  4. Then install fresh copy of WordPress in your new server with a fresh database.
  5. Then replace the new installation wp-content folder with your previously downloaded one.
  6. After that delete all the table from new database and import the downloaded database. May be some time you also will be needed to delete the new database then create another one with the same name and downloaded database SQL file. But it depends how you downloaded the database.
  7. Lastly you need login to the wp-admin, then have to go to Settings >> Permalinks and then have to hit Save Changes. It will re-generate your .htaccess file.

Hope that thing helps.

  • Hi, thanks. I followed all of these steps the first time around. I already replaced the content files and imported them all into the media library. The problem is just that they images are not loaded into the theme anymore wherever you need to set one. – RJCurcuru Oct 22 '16 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.