0

I am working on a website and got stuck to an issue, whenever I access website.com it redirects me to http://website.com/continent/asia/ and I don't know why.

This is a custom post type called continent, and the Asia is set in WP settings as the front page. Why does my homepage show /continent/asia in url and not just www.website.com ? The .htaccess files is okay.

If I assign other page as homepage the url is clean www.website.com, if I assign any continent (CPT) the url gets the /continent/asia .

Is there something I'm missing?

  • It seems that some plugin is doing this, how did you create the CPT? – Nabil Kadimi Oct 19 '16 at 18:37
0

You can go to settings> general> and make sure the wordpress address(URL) and the Site Adress(URL) is set to http://website.com/ and not http://website.com/continent/asia/

  • Thanks for the reply, the general settings are website.com I checked the options table in Database and it's also website.com it's not website.com/continent/asia – Radu033 Oct 19 '16 at 18:16
  • A work around it would be: You can always create a custom template in your theme file, Then create a page and then assign that page as the front page. IN the custom template you can assign one specific category to that page: query_posts('cat=80'); (80 will be the category) – Charles Xavier Oct 19 '16 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.