0

I'm having an issue with WordPress where the Page isn't Updating if the Visual Editor is Empty. Here are the steps I am taking:

  1. Go to Pages
  2. Click on an existing page to Edit
  3. On the Edit Page screen, Remove all the text from the Visual Editor so that the Visual Editor is blank
  4. Click Update

RESULT: All the text that was just removed is in now back in the Visual Editor. The page was not updated.

Solutions Tried: All plugins are Deactivated, Using the default TwentySix theme, Reinstalled Core WordPress files, Repaired and Optimized Database.

I can successfully update the page with an empty post_content table within phpMyAdmin.

Please help.

  • Is WP_DEBUG enabled? – czerspalace Oct 19 '16 at 17:28
  • Yes, I'm using WP_DEBUG, true – katart Oct 19 '16 at 17:29
  • I just tested and this seems to be happening to all sites on the server. I spoke with the server admin and they're not sure what the problem would be. They thought it might be the memcache module but that wasn't it. Do you think it could have something to do with MariaDB 10? – katart Oct 20 '16 at 15:39
1

I found the reason for this problem!

The server admin found that the culprit was the suhosin PHP extension. They disabled the extension and replaced it with cagefs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.