1

I'm working on a child theme of "colormag" theme. It works in developmet but not when I deploy it to staging.

It means that changes I made in the child theme are rendered in local but are not rendered in remote.

UPDATE: It is a Trellis/Bedrock project. I think the issue is related to WP, not to Trellis. To see the entire theme and child theme in context: https://github.com/aitormendez/obrunete/tree/master/web/app/themes

This is the header of my colormag-child/style.css file:

/*
 Theme Name: ColorMag child
 Author: Aitor
 Template: colormag
 Version:      1.0.0
 Text Domain:  colormag-child
*/

This is the header of style.css original colormag theme (I don't know whether is relevant):

/*
Theme Name: ColorMag
Theme URI: http://themegrill.com/themes/colormag/
Author: ThemeGrill
Author URI: http://themegrill.com
Description: ColorMag is a perfect responsive magazine style WordPress theme. Suitable for news, newspaper, magazine, publishing, business and any kind of sites. Get free support at http://themegrill.com/support-forum/ and check the demo at http://demo.themegrill.com/colormag/
Version: 1.1.5
License: GNU General Public License, version 3 (GPLv3)
License URI: http://www.gnu.org/licenses/gpl-3.0.txt
Tags: one-column, two-columns, right-sidebar, left-sidebar, flexible-header, custom-header, custom-background, custom-menu, custom-colors, sticky-post, threaded-comments, translation-ready, featured-images, theme-options, post-formats, footer-widgets, blog, e-commerce, news
Text Domain: colormag

Resetting and rebuilding styles have been helped along thanks to the fine work of
Eric Meyer http://meyerweb.com/eric/tools/css/reset/index.html
along with Nicolas Gallagher and Jonathan Neal http://necolas.github.com/normalize.css/
and Blueprint http://www.blueprintcss.org/
*/
  • Is there something wrong in the child theme header?
  • If yes, why is it working on local?
  • If not, Why is not it working on remote?

Thank you very much.

  • What is not working? Is WordPress up and running? Does it work when you activate a stock theme (twentysixteen)? Have you looked at the server's error logs? – Florian Oct 19 '16 at 4:23
  • Sorry for the ambiguity. WP works perfectly. Don't work means that changes made in the child theme are not renderer in remote. I go to update the question whith this info. – aitor Oct 19 '16 at 5:52
1

Sorry to say, but the problem was that, in production, I had activated the parent theme instead of child theme. I am embarrassed by this cluelessness and I apologize for making you waste your time

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.