0

I have a wordpress project in which I need to install the plugin WP Video Post

For this ffmpeg needs to be installed. I have wamp installed on my local wamp server and the version I am using is: Apache Version: 2.4.23 - Documentation PHP Version: 5.6.25 - Documentation Server Software: Apache/2.4.23 (Win64) PHP/5.6.25

I have downloaded ffmpeg dll from http://myownhomeserver.com/wp-content/uploads/2012/12/ffmpeg6-php54-win64-vc9-all.zip and did he following:

  • Copied the php_ffmpeg.dll to wamp/bin/php/php5.6.25/ext folder
  • copied the rest files in C:\Windows\System32 folder
  • Added extension=php_ffmpeg.dll in php.ini file
  • Restarted the wamp server

After restarting this wamp server I got this error message in PHP error log as below:

[16-Oct-2016 23:44:08 UTC] PHP Warning:  PHP Startup: ffmpeg: Unable to initialize module Module compiled with module API=20100525 PHP    compiled with module API=20131226 These options need to match  in Unknown on line 0

[16-Oct-2016 23:44:08 UTC] PHP Warning:  PHP Startup: ffmpeg: Unable to initialize module Module compiled with module API=20100525 PHP    compiled with module API=20131226 These options need to match  in Unknown on line 0

I tried to search ffmpeg dll that is compatible with this php version, but no luck. Can anyone help me to find out the issue that has occurred and resolve this issue?

Thanks in advance

  • This really has nothing to do with WordPress and should probably be migrated to StackOverflow. – Milo Oct 17 '16 at 0:54
  • Hey @Milo, thanks for the reply. I actually have created the one on stackoverflow too but didn't hear anything from anyone. So I have posted here. Here is the link for this issue stackoverflow.com/questions/40070954/… – user478 Oct 17 '16 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.