0

My website is very, very slow. Using Query Monitor, I diagnosed slow HTTP Requests, taking up to 40 seconds (usually 12 secs).

These HTTP Requests are POSTs to http://website.com/wp-cron.php?doing_wp_cron=1476656604.8787710666658495142625

I've tried to disable WP-CRON in wp-config.php with define('DISABLE_WP_CRON', true); but it changed absolutely nothing.

Query Monitor enter image description here

Core Control enter image description here

I have only a handful of cron tasks scheduled, according to Core Control.

The question is: What approach should I take to diagnose and solve this problem? Why would a POST to localhost take so long?

0

Solved it.

Turned out I had to include define('DISABLE_WP_CRON', true); BEFORE the line where it says /* That's all, stop editing! Happy blogging. */, where it includes wp-settings.php.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.