0

I first updated my PHP version from 5.3 to 5.6 and then to 7. Everything seems to work fine except for 2 things. Both on 5.6 and 7.

The front page won't load (!) and the custom css from the Simple Custom CSS plugin isn't being applied to any of the other pages.

I get a status 200 code when I load the front page but nothing happens.

The only error in the debug log is this: PHP Notice: Undefined offset: 1 in /var/www/html/wp-includes/class-wp-xmlrpc-server.php on line 6331

Also I can't load my info.php file, it results in a page not found error.

I'm using a LAMP server on AWS EC2.

PHP v7 apache v2.4.23 Mysql v5.5.52

Maybe I'm missing a PHP module?

These are the activated modules:

bz2 calendar Core ctype curl date dom exif fileinfo filter ftp gettext hash iconv imagick json libxml mysqli mysqlnd openssl pcntl pcre PDO pdo_mysql pdo_sqlite Phar posix readline Reflection session shmop SimpleXML sockets SPL sqlite3 standard sysvmsg sysvsem sysvshm tokenizer wddx xml xmlreader xmlwriter xsl zlib

Or do I need to change a setting in my httpd.conf file? I changed allowoverride to all. Also deleting my .htaccess file doesn't seem to fix it so I don't think that's causing it?

I don't really know what I'm doing so I'd appreciate some help!

0

Finally solved it! The front page was loading index.html instead of index.php. I added "DirectoryIndex index.php index.html" to the .htaccess and that fixed it. Also fixed the custom css.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.