0

I have a self-hosted wordpress blog with bluehost. I pretty much have all settings set to default. I've had it for a couple of weeks, and just today, when I try to edit a published post I get a redirect back to the main posts page and the changes are not saved. I went back and saved increasing chunks of the content to see if there was a weird character or something, and I found out that around 1400 words it pretty consistently fails.

I have tried changing the define('WP_DEBUG', true); and define('WP_DEBUG_LOG', true); in my wp-config.php but I don't see any erros in wp-content/debug.php.

I have also deactivated all my plugins and the theme. Same error.

I have no idea what else to do.

  • 2
    do you have the access to the /error.log file? Are you using nginx. I think this is on BH. Are you on shared hosting? – prosti Oct 15 '16 at 23:18
  • @prosti You brought me one step closer! I found this line in wp-admin/error_log POST data can't be buffered; all data discarded in Unknown on line 0 Still no idea of how to fix it – nachocab Oct 16 '16 at 0:09
  • 1
    Sounds like a PHP config error, like your reaching a max_input_vars limit, or something. – stims Oct 16 '16 at 4:19
  • 1
    I spent an hour with bluehost tech support and they said they "re-built the wp-core files". Not sure what that means, but that fixed it. Thanks for pointing me in the right direction! – nachocab Oct 16 '16 at 11:36
  • @nachocab If you got it fix by tech support then post this as an answer by providing as much detail as you have regarding your solution. Even if minor detail/hint you got from tech support then you should share it as an answer Because not all users use to read comments. – Rishabh Oct 17 '16 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.