1

I'm developing a site with the Advanced Custom Fields and SF Taxonomy Thumbnail.

In any page (post type = page), I'm with an error that I don't know what is happening:

Error

My custom template code: https://gist.github.com/gabfr/79e1c915d0b2f9ed6620aee7fdc8c8b0 (similar to the page.php)

I don't have custom filters in my function.php, and I already tried to deactivate the plugins. None of them worked.

Someone experienced this error before?

  • 1
    Never use page-{something}.php as a page template as it is a part of template heirarchy. Also use home_url() instead of bloginfo('url'). – bravokeyl Oct 10 '16 at 17:31
  • @bravokeyel thanks for the tips, still not working :( – Gabriel Ferreira Rosalino Oct 10 '16 at 18:19
2

My error was on line 21, the global variable $pages is used by the wordpress. Overwriting it on that line caused the error above.

  • Perhaps you could tell a little bit more how you tracked this down from get_the_content in post-template.php. Just a little lesson in bug tracking... – cjbj Oct 10 '16 at 19:55
  • Here's a list of reserved terms that could cause conflicts with core functionality too. – Greg McMullen Oct 11 '16 at 0:42
  • @cjbj I went to the root of the error (post-template.php file) and tried to understand the line of codes around the line of error. I saw the declaration of global variables at the top of the method. – Gabriel Ferreira Rosalino Oct 18 '16 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.