1

I know it has been asked over and over again on the internet and i spend hours digging deeper into the web. But the no answer so far.

Why we get this error when you upload a file
The uploaded file could not be moved to wp-content/uploads

  1. I tried various file persimission on folders and files in the ftp.
  2. Tried a fresh install WP.
  3. I tried this code define( 'UPLOADS', 'wp-content/uploads' );
  4. I tried adding the path in the wp/options.php location for upload_path.
  5. I created the upload folder manually, because when i installed WP the wp-content folder does not have any folder named uploads

But nothing so far..

Local Server
There is no issue so far in the local server.

I am just a beginner and learning WordPress from scratch. The only issue i got stuck is this file upload thing.

Can anyone help me!

2
  • 1
    Whatever user your webserver runs as must have write access to the wp-content/uploads directory in order to upload files. You may have to consult your hosting company for assistance.
    – Pat J
    Oct 13 '16 at 14:42
  • @PatJ i tried all the permission, and nothing seems to working. Alternatively iam using an external URL to upload the file.
    – Dexter
    Oct 14 '16 at 4:09
0

I experienced this error while preparing an AWS ec2 Bitnami micro-instance configured for WordPress. This approach requires the command-line, so please launch a terminal-session and begin via SSH into the deployed production.

  1. cd into the application document-root:

    /home/bitnami/apps/wordpress/htdocs:

  2. Execute the below command to identify the Apache web-server:

    ps aux | egrep '(apache|httpd)'

    Revealing daemon in this case, as captured within the terminal-output screenshot below:

    enter image description here

  3. Ultimately, the below-command remediated the error; users should now have the ability to successfully media-upload content via the WordPress Content Management system/admin-panel:

    sudo chown -R daemon:daemon wp-content

I recommend the following dox for guidance regarding the Linux-commands referenced herein:

1
  • Thanks for the answer, i found it that you have set the permission level in the hosting service provider's folder settings. Once it is done. The folder was created automatically.
    – Dexter
    Apr 18 '17 at 5:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.