4

How can I allow people to post comments on a page?

I've put this into my page template: <?php comments_template(); ?> but it just says at the bottom of my page "Comments closed".

UPDATE: If I can allow comments for one specific template for a page that would be great.

  • 2
    have you checked 'settings' 'discussion', and for individual pages, under 'pages' and 'quick-edit', or the 'discussion' area in 'edit page' below the page editor? when the last one does not show, click 'screen options' near the top right, and tick 'discussion' there, then scroll back down... – Michael Jul 26 '11 at 13:08
  • @Michael Ahhhhhh, the screen options solved it, thanks!! – Rob Jul 26 '11 at 13:12
  • Michael you should add that comment as an answer.. ;) – t31os Jul 26 '11 at 13:16
  • consider it done ;-) – Michael Jul 26 '11 at 14:17
  • RE: Allow comments for one specific template - Comments can be enabled selectively for pages already, that's what the discussion metabox is for, check (or not) as necessary when creating/editting the page. Is the current functionality not sufficient for your needs? – t31os Jul 26 '11 at 14:48
10

Have you checked under Admin -> Settings -> Discussion and for individual pages, under pages and quick-edit or the discussion area in edit page below the page editor?

When the last one does not show, click screen options near the top right, and tick discussion there, then scroll back down.

  • 1
    Made some minor tweaks to make the answer a little easier to follow, only minor but makes all the difference for readability. – t31os Jul 26 '11 at 14:44

protected by Community Dec 13 '16 at 15:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.