0

I'm am setting up my first network site on a subdirectory based network.

My .htaccess is copied directly from the "Network Setup" page of the network admin panel. This is currently in the file:

# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
# END WordPress

And the correct section of my wp-config.php file was copied from the same page, save the first definition:

define( 'WP_ALLOW_MULTISITE', true );

define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
define( 'DOMAIN_CURRENT_SITE', 'example.com' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );

The resources on the front-end and the admin panel are being requested from https://example.com/ whenever we go to https://example.com/ and from https://example.com/site1 whenever we go to https://example.com/site1. This is the part I'm not familiar with, is that expected functionality?

What am I missing to be able to successfully request the resources needed to fully render the page?

  • Is this a brand-new webserver? Make sure that Apache's mod_rewrite module is enabled. – Pat J Sep 23 '16 at 19:30
  • 1
    @PatJ It was a file permissions issue. Thank you for your input, though. – ExcellentSP Sep 30 '16 at 17:02
0

In this case, I had to reset the some of the file permissions of the WP install to 775. The the fault was with the managed hosting provider having this problem with many of their multisite installs.

| improve this answer | |
  • 1
    Which files did you have to reset specifically? – circlecube May 10 '17 at 15:23
  • @circlecube I wish I could tell you, but the hosting provider has a "Reset File Permissions" button in the install management panel. I pressed it, and it worked! – ExcellentSP May 13 '17 at 16:10
0

Thanks everyone for posting. I've recently ran into this same issue and have spent numerous hours myself trying to determine what the issue is. Unfortunately my hosting provider does not support multisite WP installs, so I'm hoping that either resetting the permissions, or downgrading or installing a fresh install of WP version less than 4.7.2 will do the trick!

More information can be found here: https://wordpress.org/support/topic/wordpress-4-7-2-update-on-multisite-causes-wp-admin-redirect-loop

I'll keep you posted as to my progress.

Cheers, Nick

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.