0

Recently I have installed a new version of WordPress and immediately I tried to change permalinks to /%postname%/ and now it's not showing the result.

Everything is default according to WordPress.org and nothing has been added to the theme or admin panel. What could be causing this issue?

  • Rename your .htaccess file from your root folder of wordpress and then change permalink from dashboard -> settings -> permalink. See if that helps. – Rishabh Sep 21 '16 at 5:33
  • not working such way. – Salman Razak Sep 21 '16 at 5:38
  • After renaming did you change permalink from setting? Change it to any other permalink and save it. After renaming click on save button of permalink is required because by clicking on save button it will create new .htaccess file. Check if by clicking on save button new .htaccess file has been generated or not. – Rishabh Sep 21 '16 at 5:52
  • 1
    i enable rewrite module in httpd.conf file and it start working. – Salman Razak Sep 21 '16 at 6:47
  • 1
    Ah great! Now post your solution as answer so that it can be helpful for future viewers. And accept your answer after 2 days because before 2 days of posting question you can't accept your answer. – Rishabh Sep 21 '16 at 6:51
0

Flush your permalinks.

To flush WordPress rewrite rules or permalinks (usually needs to be done manually for new custom post types) from the Dashboard:

Step 1: In the main menu find and go to "Settings > Permalinks".

Step 2: Click "Save Changes".

  • I didn't get your step 3. After save changes on step 2, what else we need to do and on what place/option/file? – Rishabh Sep 21 '16 at 7:13
  • All you need to do is go to settings>permalinks and then click save changes. This flushes your permalinks and they should be working? Just ignore step 3. – stemie Sep 21 '16 at 7:16
0

i enable rewrite module in httpd.conf file and permalink for wordpress start working. Even its new version of wordpress that is 4.6 disabled rewrite module causing error page. Once you enable it and refresh your wamp it let you view your pages.

0

Maybe your .htaccess file is not writable if you are using debian or Linux based system aur Mac base system there are must be chances off the permission issue of the .htaccess file.

First you need to check that that file is writable or not why WordPress?

Because wordpress changes active .htaccess by own if you change any permalink settings wordpress changes the .htaccess file.

if file is not writable then wordpress cannot be able to change your .htaccess file.

all Preeti permalinks works on the wordpress .htaccess file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.