0

I have been struggling with this one and cannot find an answer. I am not an expert with databases and had an issue that is a pain.

I am attempting to migrate a wordpress database to a different server host. The current MariaDB version is 10.0.20 and the new one is 5.5.50

I used phpmyadmin to dump the database I imported it to the new host and got this issue. https://stackoverflow.com/questions/21190523/phpmysql-error-1273-1273-unknown-collation-utf8mb4-general-ci

I resolved by following the sollution to use MYSQL40

Then trying again I got an issue with TYPE=INNODB.

https://stackoverflow.com/questions/9620439/syntax-error-when-running-a-mysql-create-table-statement

Found the solution and changed TYPE=INNODB to ENGINE=InnoDB in the dump.

Now I get this error and I have no idea how to resolve and found nothing useful

Warning in ./libraries/dbi/DBIMysqli.php#252
 Error while sending QUERY packet. PID=2622

Backtrace

./libraries/dbi/DBIMysqli.php#252: mysqli_query(
object,
string 'SHOW SESSION VARIABLES LIKE \'FOREIGN_KEY_CHECKS\';',
integer 0,
)
./libraries/DatabaseInterface.php#240: PMA\libraries\dbi\DBIMysqli->realQuery(
string 'SHOW SESSION VARIABLES LIKE \'FOREIGN_KEY_CHECKS\';',
object,
integer 1,
)
./libraries/DatabaseInterface.php#1586: PMA\libraries\DatabaseInterface->tryQuery(
string 'SHOW SESSION VARIABLES LIKE \'FOREIGN_KEY_CHECKS\';',
object,
integer 1,
boolean false,
)
./libraries/DatabaseInterface.php#1380: PMA\libraries\DatabaseInterface->fetchValue(
string 'SHOW SESSION VARIABLES LIKE \'FOREIGN_KEY_CHECKS\';',
integer 0,
integer 1,
object,
)
./libraries/DatabaseInterface.php#1400: PMA\libraries\DatabaseInterface->getVariable(
string 'FOREIGN_KEY_CHECKS',
integer 1,
object,
)
./libraries/Util.php#3328: PMA\libraries\DatabaseInterface->setVariable(
string 'FOREIGN_KEY_CHECKS',
string 'ON',
)
./import.php#636: PMA\libraries\Util::handleDisableFKCheckCleanup(boolean true)

Hopefully someone might have a suggestion. Thank you

  • try to load the dump without these lines with SHOW SESSION ... – mmm Sep 17 '16 at 9:30
  • just errase them of the dump file – mmm Sep 17 '16 at 10:12
  • I have found this stackoverflow.com/questions/2429655/… But even that is not working. For some reason even though I can telling the import to not check FOREIGN KEYS it still does anyway – dgibbs Sep 17 '16 at 10:52
0

This looks like a Foreign Key issue.

When you use PHPMyAdmin to create the sql dump, try using the custom settings to disable Foreign Key checks.

  • Thanks..Very odd. I have disabled foreign key checks when creating the dump and disabled when importing but in the error it states that's its on. – dgibbs Sep 17 '16 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.