2

Firstly I tried to post this question on wordpress support with hope that they must know about this issue because its official forum of wordpress but I didn't get any reply from them. So now I am here to find solution.

Problem comes after update. When I add page in menu (Appearance -> menu) and click on save then it converts into custom link. And in that custom link there is no field to enter url! It starts happening after update of wordpress.

Before update it was fine. The menu that I have created before update is fine but after update I can’t add pages (because it converts into link).

One more think, When I add multiple pages i.e. 2 then one page convert into link and other remain safe. That’s mean if I have to add single page in menu then I have to select 2 pages and add it in menu. When I click on save changes then one page converted into link (mostly page at bottom of 2 page or second one from 2 pages) and other remain safe. So then I delete custom link and save changes again then I gets my desire page on menu.

Another effect of that activity is that when I try to update menu then my pages in which I selected custom template that pages revert back to default template when ever I click on save changes in Appearance -> menu. May be this happening because of menu issue (converts page into link).

Solution that I have tried: 1. I disabled all plugin

  1. I tried to switch to twentysixteen but didn't works
  2. I also try solution posted on this article. As per above post suggestion I increased memory to 1000 to 5000 but still no effect.

I have searched a lot but didn't find any solution that work for me. So any idea what else should I try to solve this issue?

0

The issue was in table structure of wp_post. The wp_posts table's ID field is somehow lost it's functionality of increment automatically. Means when new row use to add in the table then ID field suppose to increment by 1. But it was not happening after update.

So I just edit table structure and make it primary key and assign auto increment and Problem got solve in minute.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.