3

I have comments enabled on my site but the form isn't appearing. It worked at one point as there are comments on some of my posts with links to them but they don't appear on the page.

Take this post: https://arcath.net/2016/03/react/ The theme is clearly showing 1 comment at the top of the page.

Comments are enabled in Settings -> Discussion

Discussion Settings

Post Options

I've read a lot of forum posts on the subject that lead me to these settings but I can't see anything wrong with them.

4

Stupid question : Is it possible that your theme doesn't include the comments on display?

In addition to settings, your theme must display comments.

The default function provided by WP is comments_template (to use on single.php and/or page.php) :


 comments_template( '', true );

UPDATE ---------------------------------------------------

I believe there is something wrong with the theme "hueman".

I installed it on a local WP containing sample contents.

When I go to an article containing comments, I have the exact same result as you get.

If I display the exact same article using a different theme (one of the defaults provided), the comments are displayed.

So I checked the single.php template file of the hueman theme and it use a custom function ( hu_is_checked('post-comments') ). Used in:

if ( hu_is_checked('post-comments') ) { comments_template('/comments.php',true); }

The problem is: it return null (so the comments can't be displayed).

According to the theme documentation, we should be able to customize the theme options through the customizer http://docs.presscustomizr.com/article/113-customizr-theme-options-comments This option is located in : Customizer > Content Panel > Comments

Unfortunatly I wasn't able to found it : I tried on front page, single post, page, never saw it.

So, since the option is not defined, the custom function will always return null.

A quick fix would be to create a child theme of hueman, overwrite single.php template and change the line for:

comments_template('/comments.php',true);

I tested it, it works.

A better solution would be to contact the theme author to see if we missed something or if it's a bug.

2

Follow three steps :

  1. Can you check in your post edit page. Many themes have an Meta Box with an option to enable and disable Comments in post's edit page.

  2. If you have checked there and still is is not coming then please check your theme's file if comments_template is there or not.

  3. If it is there, then are you using any comments related plugin such as Disqus or Facebook Comments. Please try deactivating those.

Hope with the above option you will get your solution.

  • There is a theme meta box which has no options for comments. The theme calls comments_template where is is supposed to and I have no comment related plugins installed. – Arcath Sep 8 '16 at 13:21
  • Can you paste the screenshot for themes meta box. And also try to turn on the WP_DEBUG. might be it can help to debug in faster way – Aftab Sep 8 '16 at 13:22
  • Posted screenshots. WP_DEBUG shows nothing on the page. – Arcath Sep 8 '16 at 13:34
1

I just had to post this as I was going thru the same thing. I'd edited the post that "came with" the initial set up. Seeing as the post was from a year ago, I thought I'd 'post date' it (pun intended). But the comments box wouldn't show up. So, I created a brand-new post, and left the publish date as of right now, actual time. The comments box showed up. I created another post, left it at the immediate time, and hey presto, it worked. I even switched themes to see and yes, the comments box(es) were there on the two posts. So, don't back date something and see if that works for you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.