2

Has anyone met this problem :

When I click Network enable on any theme: enter image description here

then after page is reloaded, the same thing happens - the theme is not enabled, and there is still "Network Enable" . I have deleted all plugins, but still same problem.

3
  • 1
    Did you saved the rewrite_rule when you initiated multisite ?
    – CodeMascot
    Sep 1, 2016 at 11:54
  • yes. sub-sites at this moment are working with the default twentysixteen, but even twentysixteen is showing "Network enable" in mainsite.
    – T.Todua
    Sep 1, 2016 at 11:58
  • found solution and answered.
    – T.Todua
    Sep 1, 2016 at 13:05

1 Answer 1

3

Finally I've found that, in wp-sitemeta DB table, allowedthemes record value was incorrectly serialized (dont know why) and there was a:4 (instead of a:3, because actual length of array was: 3 values of s:)

a:4:{s:13:"twentysixteen";b:1; s:5:"meris";b:1; s:8:"my_theme";b:1;}

I changed a:4 to a:3 and it worked. (also, make sure there is no more allowedthemes rows in wp-sitemeta table)

4
  • Glad that you've solved your own question, be sure to click the checkmark after two two to indicate that this question has been resolved Sep 1, 2016 at 23:31
  • @EthanJinksO'Sullivan I think that if i make my own answer checkmarked, i will get a penalty for Bounty-boosting. Am i right?
    – T.Todua
    Sep 2, 2016 at 7:53
  • Nope, you won't get any reputation for solving your own answer, and we actually encourage people to answer their own questions. I've done it a few time myself. Sep 2, 2016 at 10:16
  • This just helped me fix a similar problem. Thanks!
    – mkopala
    Jul 17, 2018 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.