1

I have a question regarding a website I am working on. The problem: WordPress redirects me to homepage if I click on update in the admin section. It only does that if I add more text to the webpage and it also does not do that on all the posts or pages. It only does that on some.

This I have checked:

The problem is only on the new live server, not the development one.

I have tried removing all plugins and the theme. I have also removed all caching. When I got in touch with the hosting company to increase the php memory, it did help I think, as I was able to update more posts, but it did not solve the problem completely.

Now, the question is, why it redirects me to homepage? Because if it was some memory issue, I think it should throw errors, not redirect me to homepage, am I right?

I hope someone had similar experience. I did look for people with similar issues, but I did not find any having the same problem.

Thank you for all your help!

Josif

  • Does it happen to only for the old posts or pages? Or only for a post type ? – CodeMascot Aug 23 '16 at 10:17
  • No, it happens randomly to all posts, pages and post types. I think it has something to do with post lenght actually. If I publish short post, it is fine. Is its long, than it redirects. – Josif Aug 23 '16 at 11:22
  • Not entirely sure this will help. But you might want to look at your .htaccess file. More details about the .htaccess on WP Codex – Greg McMullen Aug 23 '16 at 15:09
  • Hi Greg, thank you for suggesting this, I did actually previously looked into this, but it looks like there is an issue with 301 redirects. It turned out, that it is the WooCommerce plugin. Normally, if you deactivate it, it breaks the the shop, but not the whole website. However if I deactivate it, it gets me into redirect loop! Any idea how to solve that? I have already reinstalled the plugin, it did not help. It also should not be a plugin conflict, as I had all the other plugin inactive and only WooCommerce was working, but after I deactivated, it still went the loop. Any ideas please? – Josif Aug 24 '16 at 9:37
  • Anyone ever had similar issues with WooCommerce please? Thank you, Josef – Josif Aug 25 '16 at 14:35
1

I was running into this due to the OWASP ModSecurity rules enabled on the server and causing false positives. Disabled, solved. Not a new problem.

0

Just to close this topic, the problem was the server of the website, we decided to move it and it is fine. So if you ever experience redirects to homepage when you click on update button in WordPress, this might be the problem.

Cheers,

Josef

  • So you don't know exactly what server setting the problem was? – Ethan C Jan 31 '17 at 22:44
  • I am sorry, I do not know. – Josif Mar 20 '17 at 12:22
0

i had this issue and i turned out my WP Firewall plugin had a false positive for a "WordPress-Specific SQL Injection Attack."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.