1

I am setting up a WordPress site locally from a site online. I downloaded the files and database. I used InstantWP to set up the site. I imported the database and moved over the proper files for the local site. When I go to the site, I get these errors:

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'wp_maybe_load_embeds' not found or invalid function name in C:\Users\William\Desktop\InstantWP_4.5\iwpserver\htdocs\wordpress\wp-includes\plugin.php on line 525

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'rest_cookie_collect_status' not found or invalid function name in C:\Users\William\Desktop\InstantWP_4.5\iwpserver\htdocs\wordpress\wp-includes\plugin.php on line 525

Fatal error: Class 'WP_User' not found in C:\Users\William\Desktop\InstantWP_4.5\iwpserver\htdocs\wordpress\wp-includes\pluggable.php on line 38

Can someone explain to me what these are and how I can fix them?

  • What version of Wordpress is this? Are the versions of PHP on InstantWP and your server the same? – Fencer04 Aug 16 '16 at 19:53
  • It is Wordpress 4.6, PHP is 5.3.2. for both. – William Hodge Aug 16 '16 at 20:04
  • 1
    PHP 5.3.2 is old and technically no longer supported by Wordpress. That being said I don't think that is the issue. I was just typing in what Ethan answered below so I'd start here. – Fencer04 Aug 16 '16 at 20:08
1

The issue was actually with the database. I had to bring it down and install again and it worked out. Thanks for the help from everyone.

1

This looks like a migration issue. Did you made sure you've updated the link of your local WordPress install to your new URL?

Changing the home and siteurl in your wp_options table is not enough unfortunately. You will still have your post content with your non-localhost URL (http://web.site) causing your website to not display properly on your localhost.

You should have the wp_options table on your localhost copy. Everything should be intact. To make sure exported your database from your live site correctly, please follow these quick instructions provided by WordPress.

Once you've downloaded and imported your database to your localhost. Follow these steps:

  1. Go and download Interconnect IT's Database Search & Replace Script here
  2. Unzip the file and drop the folder in your localhost where your WordPress is installed (the root) and rename the folder to replace (screenshot)
  3. Navigate to the new folder you created in your browser (ex: http://localhost/wordpress/replace) and you will see the search/replace tool
  4. It should be pretty self-explanatory up to this point: enter your old URL in the search for… field and the new URL in the replace with… field

You can click the dry run button under actions to see what it will be replacing before you execute the script. Once you're done be sure to remove the /replace/ folder.

  • Hi Ethan. Thanks for the suggestion. I ran the query. Site url and home were changed but I'm still getting the errors. Do you have any other suggestions? – William Hodge Aug 16 '16 at 20:52
  • Ethan, I got it to work. Thank you for your help. – William Hodge Aug 16 '16 at 21:19
  • Glad to hear William, be sure to upvote and click the checkbox to let users know this answer helped you. – Ethan Jinks O'Sullivan Aug 16 '16 at 21:21
  • @WilliamHodge Please let us know what you did to get it working, if it wasn't what was in this post - it will help other users :) – Tim Malone Aug 16 '16 at 23:35
  • @WilliamHodge did my solution help? – Ethan Jinks O'Sullivan Aug 20 '16 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.