1

I have set up a fresh installation of WordPress 4.5.3 and activated the Multisite feature, following all the instructions required to activate it.

I added a second site, and once it was created I tried clicking on the dashboard for the second site but it directs me to the first site dashboard, everytime!

I tried to visit the second link I made - for instance www.example.com/ar - and it shows the website without the theme and with the wrong links. Again I try to go back and edit it; again it redirects me to the main site.

What can I do to resolve this?

My domain is registered through GoDaddy.

2
  • well I ran into something similar, to fix it I had to disable all plugins and it then led me to the the one that was causing issues. Have you tried that yet? Jul 18 '16 at 16:54
  • No sir, but i am trying to find the solution soon.
    – Zak Hamdi
    Jul 18 '16 at 23:39
1

Make sure you've set up your rewrite rules in your .htaccess file. The Multisite rules are different from the default WordPress rules.

If this is an up-to-date version of WordPress, your .htaccess rewrite rules should look like this:

Subdirectory

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

Subdomain

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]

See the Codex page on .htaccess for more details.

1
  • Nope, I have tried this code before and it is not working.... any more ideas?
    – Zak Hamdi
    Jul 18 '16 at 23:11
0

I assume that the culprit here is GoDaddy. It looks like the GoDaddy setup prevents users from editing the Siteurl and Home URL setting of a site in a multisite network. You can try to customize the URL but the change doesn't get saved:

Can't save Siteurl with GoDaddy in Multisite network

The only solution I found so far is to manually update both values in the database. Once you've accessed the database, look for a table wp_SOMETEXT_2_options ("2" is the ID of your site in the multisite network), browse it and update the option_value cells:

Manually update Siteurl in GoDaddy database

Once you've updated those cells, the updated Siteurl and Home URL should now be displayed in the settings tab in your WordPress backend. Additionally, make sure that the Site Address is up-to-date. You should be able to update the Site Address from the WordPress backend:

Update site address in GoDaddy WordPress site

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.