0

While editing or writing a new post, sometimes I get redirected to the following address: https://www.examplesite.com/wp-login.php?redirect_to=https://www.examplesite.com/wp-admin/edit.php&reauth=1

Even though i wasn't navigating using https. We don't have an SSL certificate for our domain, so we get the following warning message: "There is a problem with this website’s security certificate."

I have around 30 wordpress websites hosted on Hostinger, and all of them gives this issue.

Any idea what causes it? I've seen a temporary solution might be adding

$_SERVER['HTTP_HOST'] = $_SERVER['SERVER_NAME'];

To wp-config.php, but I'm looking for a permanent solution, and the root of the problem...

  • If you go to Settings -> General in your WordPress admin, what is listed as the WordPress Address and Site Address? – Tim Malone Jun 30 '16 at 2:04
  • They are both http://, it seems it might be a session bug, I've seen other people with shared grid hosting having the same issue (ex: wordpress.org/support/topic/…) – Lucas Bustamante Jun 30 '16 at 16:38
  • I'm not sure what shared grid hosting is, but maybe you need to talk to your host then... – Tim Malone Jun 30 '16 at 19:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.