0

I have multisite setup and I'm using the WordPress MU Domain Mapping plugin so I can control other domains with multisite. I have it installed on a subdomain to act as my command location. I plan to connect main sites and staging sites:

  • maindev.site1.com (mutlisite install)
  • dev.site1.com
  • site1.com
  • dev.site2.com
  • site2.com
  • etc

because I'm installed in a subdomain and the way the hosting works my multisite is subdirectory based so dev.site1.com is actually maindev.site1.com/dev.

The issue instead of links being dev.site1.com/hello-world they are maindev.site1.com/dev/hello-world. Both work but the links are correct. I've tried reseting permalinks but it didn't work.

2

I figured this out right after I posted the question but thought it would help someone who ran into the same issue. I have to go to:

Network Admin -> Sites -> edit a site -> Settings -> change "site url" and "home"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.