-1

My page permalinks are http

permalink http

Settings -> Site & Home URL set to http://

but the links all go to https:// It seems all my page permalinks are being rendered as https.

I do not have any redirect rules in my .htaccess that are making this happen.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /apps.abc.com/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /apps.abc.com/index.php [L]
</IfModule>
# END WordPress

I'm stumped, been at this for a little while and can't for the life of me figure it out. I know it's going to be something really dumb I did or didn't do, I'm hoping someone can point it out.

0

Try this in your wp-config.php

define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com');

This basically hard-codes the WordPress options for siteurl and home, which will means WordPress will redirect all requests to those URLs.

This won't change any permalinks in any content that you have in your site -- to do this I'd recommend using a plugin like WP Migrate DB to search and replace the URLs for https:// to http://

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.