1

Hi I have updated my wordpress site manually, now i get below mentioned error in the front and backend.

Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the "Main Sidebar" sidebar. Defaulting to "sidebar-1". Manually set the id to "sidebar-1" to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.)

Can anyone help?

  • 2
    The error says itself that what is wrong! – Sumit May 20 '16 at 11:09
  • 2
    @Sumit I seriously don't understand how some people can't work out these errors - you don't need to be a programmer you just need to know how to read! – TheDeadMedic May 20 '16 at 11:34
  • Because they know somebody here will fix it before they finish reading error message :D – Sumit May 20 '16 at 11:47
12
  1. Find file where is register_sidebar ( must be on theme folder or plugins )

  2. add ID to sidebar

    register_sidebar( array(
       'name' => __( 'Main Sidebar', 'theme-slug' ),
    
       'id' => 'change_me',  // Add only this line
    
       'description' => __( 'Widgets in this area will be shown on all posts and pages.', 'theme-slug' ),
       'before_widget' => '<li id="%1$s" class="widget %2$s">',
       'after_widget'  => '</li>',
       'before_title'  => '<h2 class="widgettitle">',
       'after_title'   => '</h2>',
     ) );
    

Or you can just disable notification in wp-config.php

edit WP_DEBUG to false

define('WP_DEBUG', false);
| improve this answer | |
0

Looks like you have a very old theme. You'll have to search the functions.php file for register_sidebar and make sure the $args follow the format mentioned in the codex.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.