1

We're running multiple WP installations on a VPS running Centos 7. A week ago all image uploads on all installations stopped, all we got was the HTTP Error during upload. I googled my way through a dozen instructions to fix it and none worked - then I tried restarting httpd on the server and it started working.

We had not touched the server since then, but yesterday it happened again - and httpd restart helped again. We have NewRelic running on the box and the server load & cpu usage are low and there's lots of disk space & memory available even during the error. Neither the access log or error log give any hints.

Does the httpd restart fix point to any direction?

  • I think you missed the more important parte fo the problem: Which HTTP error do you get? – cybmeta May 17 '16 at 10:40
0

Assuming that you are running 4.5, the following bug might be the reason https://core.trac.wordpress.org/ticket/36534. (In short, the more aggressive image compression introduced in 4.5 causes imagemagick to fail).

There are some suggested solutions in the ticket, but it also sounds like increasing the max memory might help.

|improve this answer|||||
  • We're not using imagemagick, even the smallest images fail and there is no timeouts, the http error appears instantly when uploading. So I don't think that's the cause. – Apeli May 19 '16 at 19:11
  • @Apeli having the errors with no noticeable time passing is exactly what described in the ticket. I suggest to try to get the jpg compression to its 4.4 state first and see if it helps (it was 90%) – Mark Kaplun May 19 '16 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.