2

I imported the Theme Unit Test xml file with the wordpress importer. But all of the data is imported as pages. I am following an online tutorial to build a wordpress theme development and I believe the data should be imported as posts.

When I proceed with the import. I can choose to import authors or to assign a existing author and I can choose to import/download attachments (which I did).

I get a fatal error

Fatal error: Maximum execution time of 60 seconds exceeded in H:\wamp\www\custom\wp-includes\class-wp-http-curl.php

I get a bunch of pages and media but no posts.

Although I am also increase those values:

max_execution_time = 5000

max_input_time = 5000

memory_limit = 1000M

How should I fix this so I can import all the content?

6
  • max_execution_time = 5000 is 83 minutes. And you still get a time exceeded error? Can you do an import using the 2015 theme?
    – BillK
    Commented May 14, 2016 at 5:40
  • No I am using 2016 theme.
    – Shadat501
    Commented May 14, 2016 at 5:47
  • Try 2015 without plugins. If it still doesn't work you might have a server configuration issue.
    – BillK
    Commented May 14, 2016 at 5:49
  • I have the same problem. How to configure this.
    – Shadat501
    Commented May 14, 2016 at 6:00
  • I don't know, every system is different.
    – BillK
    Commented May 14, 2016 at 6:05

2 Answers 2

8

I get that answer.

I go to this file: wp-includes/deprecated.php and find this line in (deprecated) wp_get_http() function:

@set_time_limit ( 60 );

just comment out this line and it works fine.

Because wordpress hard coded that 60 seconds limit, this hard coded setting was over-ridding my php.ini settings. so I comment out that line, my php.ini settings will start working again.

1
  • This solution worked only within so many online solutions for me. Thank you very much for this solution. Commented Mar 11, 2017 at 4:14
0

Just to the point.. In wp-config.php paste this code-line

set_time_limit(180);

set your recommend execution time (PHP Time Limit) and done!..

Important: Paste before

/* That's all, stop editing! Happy blogging. */

That's all.

Never forget this, Silence is golden :))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.