0

Virtual HostX and MAMP does not render the Wordpress files. Virtual HostX and MAMP are both set to port 80. However, the MAMP's Apache is not running. And MAMP's web server is set to htdocs folder

The URL is displaying - It Works! after refresh:

enter image description here

however it should prompt me to set up Wordpress like so:

enter image description here

Folder structure, as per the video tutorial:

enter image description here

VirtualHostX and MAMP setup:

enter image description here

I have followed every single step as it is in this Tutorial, multiple times, it still is not working.

Tutorial: https://vimeo.com/39957172

Please advise.

  • find a better tutorial ;). This is a general web server setting issue and out of scope here – Mark Kaplun May 13 '16 at 6:20
  • that's the problem, there is none... – Linards Berzins May 13 '16 at 20:57
1

You're wanting to use MAMP, but VirtualHostX shows that Apple's built-in Apache is running. You'll need to stop it by running this command in a Terminal window...

sudo apachectl stop

Then, start MAMP using their control panel and try again.

Also, make sure "MAMP" is set as your "Default Web Server" in VirtualHostX's Preferences window.

  • Hi Tyler, Thak you for looking into this. I did stop the Apple apache runnining, teh set up the MAMP and VirtualHostX as you instruted, however I still get the - Index Of/ now however, as you can see from the screenshot. Im really puzzled of why its like that. Could it be my Mac setup? User setup? See this screengrab for all the sofware running correctly: i.imgur.com/cHZRfg9.png – Linards Berzins May 19 '16 at 21:31
  • aaaand, now its back to (It works!) again, with exact same setup... i.imgur.com/Zlrgov9.png – Linards Berzins May 19 '16 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.