1

I have facing out of memory allocated fatal error in wordpress. i have printed the phpinfo(); and check for the memory_limit . so both values are 512M. I have also added following code in my wp-config.php file

define( 'WP_MAX_MEMORY_LIMIT' , '1600M' );
define('WP_MEMORY_LIMIT', '128M');

but the problem still persists ?

Now i have to ask either this is the host issue or some thing else in wordpress settings ?

  • 1
    Are you on shared hosting? If you are on a shared hosting it's better to ask hosting provider . – bravokeyl May 12 '16 at 8:51
  • Sorry to hear you're having problems, but this question is off-topic (too localized) - you need to liase with your hosting provider. – TheDeadMedic May 12 '16 at 9:45
  • memory limits can also be set in php.ini (or even .htaccess I think) so you can check those too, as wordpress cannot override existing limits. – majick May 12 '16 at 10:19
  • 1
    Shared web hosts restrict the PHP Memory limit at server level through php.ini file. You can create your own php.ini file in web hosting space and extend the PHP Memory limit, if your web host allows you. As an alternative, your web host must have provided you with the "Select PHP version" option in cPanel, that allows you to set PHP Memory limit along with other important variables. – AccuWebHosting.Com May 13 '16 at 6:15
1

If you are on any environment you did not personally set up, you may not have the permissions to override the php.ini file.

Also some plugins can manually do:

ini_set( 'memory_limit', '512M');

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.