I have a site with an image in the sidebar hosted on an external server. I change this image every so often on the external site, but the name of the file stays the same.

Recently, I've noticed that my site is not using the most recent version of the image. Looking at the source, instead of using the example.com/foo.png I specified, it's now using i0.wp.com/example.com/foo.png, which has a cache of an old version of foo.png.

Searching around for answers, I've come across many sites saying that Jetpack and Photon are the cause of this (for example, Why would image paths in wordpress suddenly change?). The solution for all of these seems to be to disable the Photon plugin.

The only problem is that I've never installed the Photon plugin, and any "how to disable plugins" tutorial I've found keeps pointing me to menu options I don't have, which I assume is because I don't have a premium account.

Is there a way to disable Photon as a non-premium user? (Or a way to at least prevent it from caching my external images?)

  • This sounds like its not a self-hosted Wordpress site (eg. wordpress.org site), which would mean it's off topic here. Have you tried en.support.wordpress.com ?
    – Tim Malone
    May 11, 2016 at 1:10
  • I'm not sure that wp.com questions are on topic here. Regardless, it looks like your dealing with a CDN isssue i0.wp.com; it's never a good idea to upload a different image using the same filename. You should really upload a new image with a different filename.
    – BillK
    May 11, 2016 at 1:10
  • @TimMalone - perfect timing.
    – BillK
    May 11, 2016 at 1:11
  • @BillK Photo finish. ;)
    – Tim Malone
    May 11, 2016 at 1:13
  • Whoops, in retrospect, this does seem to be off-topic, doesn't it?
    – bogardpd
    May 11, 2016 at 1:24

1 Answer 1


Just simply renaming the image will solve this problem. Because you are uploading image with same exact name the path for this image is same, so when it is cached and sent trough CDS, the path(link) because of the name stays the same, so just renaming it will solve the problem.

On the other hand if you have Jetpack installed, you can easily find photon in Jetpack settings menu. So there you have list of all features turned on. There you can find photon and turn it off.

I hope this helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.