3

I have copied my site to a subdirectory for test purposes, everything works fine now. The only problem I have seen so far is the Media upload. When I try to upload a file I get a:

Unable to create directory wp-content/uploads/2016/05. Is its parent directory writable by the server?

The wp-content folder has a 755 permission, the uploads folder also.

I tried to add this to my wp-config

define( 'UPLOADS', 'wp-content/'.'uploads');

in the section before the table prefix is set, because I thought maybe I have to tell WP that the path changed

    define( 'UPLOADS', 'unterverzeichnis/wp-content/'.'uploads');

but I get the same error.

Any Ideas?

  • 3
    Does the 2016 folder exist already? Does it have 755 permissions? – Tim Malone May 3 '16 at 6:56
  • Yes to both of your questions. I created the folder manually, because I thought this might be the problem. – Vika May 3 '16 at 13:26
  • double check the media file url in settings > media, maybe it's still set to the old url which doesn't exist – Gareth Gillman May 25 '16 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.