1

my site is https://techyuga.com.

Yesterday, I tried to change the nameserver to CloudFlare nameserver. But after that,I am getting infinite redirect loop on my website and I can't even log in to my WordPress dashboard.

However, when I changed the nameserver to my host default nameserver again. It works absolutely fine.

Could anybody help? It's quite urgent.

Note: I have checked .htaccess content, it has no redirect code.

Thanks in advance.

closed as off-topic by TheDeadMedic, Mayeenul Islam, Howdy_McGee, Mark Kaplun, bueltge May 13 '16 at 13:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – TheDeadMedic, Mayeenul Islam, Howdy_McGee, Mark Kaplun, bueltge
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    on this URL I see a website with a title "GET UNLIMITED TECHNICAL SUPPORT...". the problem is solved ? – mmm Apr 29 '16 at 10:08
  • Please note that, it is working fine as i have changed the nameserver to my host nameserver once again. Problem only arise, when i try to transfer the nameserver to CloudFlare. Thanks for your response. – jingyansu choudhury Apr 29 '16 at 10:42
  • Did you try this on a different or incognito browser? – Howard E Apr 29 '16 at 10:58
  • Yes, i have. It is not a redirect loop browser issue. Please note that, i am only getting redirect loop issue when i change the nameserver to cloudflare. What is likely happening here is that whatever is creating the redirect also has a catch in it to prevent loops when it is improperly set, however this catch isn't triggering when our proxy is in place. we will need to find where this redirect has been created, and eliminate the loop by preventing it from affecting HTTPS requests – jingyansu choudhury Apr 29 '16 at 11:05
1

Essentially it looks like CloudFlare's Flexible SSL is kicking in. Please one of try the following:

  • Enable Full SSL in the CloudFlare Dashboard under the Crypto tab
  • If this fails; you'll need to install the CloudFlare Flexible SSL plugin to get WordPress to play nicely with Flexible SSL

You can read this CloudFlare help centre article for more info: How do I fix the infinite redirect loop error after enabling Flexible SSL with WordPress?

Thanks

Not the answer you're looking for? Browse other questions tagged or ask your own question.